Общее описание системы

Navigation: »No topics above this level«

Общее описание системы

 Return to chapter overview

EverestFX Delta Project Help

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


Схема взаимодействия

Navigation: Общее описание системы >

Схема взаимодействия

 Return to chapter overview

Рис. 1. Схема построения системы EverestFX Delta

Система EverestFX Delta позволяет вести арбитражную торговлю на неограниченном количестве пар-брокеров (Рис1:Symbols Pair i Virtual Servers) в пределах одного сервера (Рис1:Server i).

Каждый из Symbols Pair i Virtual Servers состоит из:

1) Virtual Server 1 - виртуальный сервер, выполняющий функции взаимодействия системы EverestFX Delta с терминалом первого брокера, входящего в i -ую арбитражную пару;

2) Virtual Server 2 - виртуальный сервер, выполняющий функции взаимодействия системы EverestFX Delta с терминалом второго брокера, входящего в i -ую арбитражную пару;

3) Virtual Server 3 - виртуальный сервер, непосредственно выполняющий функции арбитражной торговли (принятия решений) для i -ой арбитражно пары.

Также на Server i должно быть установлено следующее ПО EverestFX:

1) EverestFX Security Authorization Windows Service. Выполняет функцию авторизации системы.

2) Everest Management Console (EverestFX Services Control). Контролирует активные интернет - соединения.


Настройка торгового терминала

Navigation: »No topics above this level«

Настройка торгового терминала

 Return to chapter overview

Настройка торгового терминала сводится к следующему:

1) непосредственной установке торгового терминала;

2) переключению торгового терминала на английский язык;

3) включение функции импорта внешних библиотек: tools->options->allow dll inputs

4) копирование папки профилей Delta в папку торгового терминала: \terminal_folder\profiles

5) копирование библиотеки libmySQL.dll в папку C:\Program Files\terminal_folder\experts\libraries

6) копирование индикатора EverestDelta3_0.mq4 в C:\Program Files\terminal_folder\experts\indicators

7) загрузка профиля Delta

8) настройка порядкового номера терминала в свойствах индикатора EverestDelta3_0


EverestFX Terminal API

Navigation: »No topics above this level«

EverestFX Terminal API

 Return to chapter overview

Рис.1. Схема управления системой EverestFX API

Database - находится на хосте системы принятия решений EverestFX Delta Core

Рис.2. Общий вид интерактивной системы управления терминалом

Нажатие кнопки "begin the process of a tradding terminal managing" инициирует запуск процессов управления торговым терминалом.

Рис.3. Пользовательские настройки программы

Рис.4. Лог действий системы

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


Настройка EverestFX Terminal API

Navigation: EverestFX Terminal API >

Настройка EverestFX Terminal API

 Return to chapter overview

Основными настройки системы хранятся в файле настроек settings.txt, находящемся в папке программы EverestFX API:

db_host:host - хост базы данных управления. Указывать хост виртуального сервера, на котором установлено ПО EverestFX Delta Core

db_name:delta - название базы данных на удаленном хосте db_host

terminal:2 - порядковый номер торгового терминала в арбитражной связке

terminal_name:MetaTrader4 - тип торгового терминала. Поддерживается MetaTrader4, MetaTrader5

ecn:yes - тип исполнения. ECN/NOT ECN (Если при открытии меню ордера Sell/Buy by Market, тогда ecn:yes)

ecn_prefix:. - дополнительная приставка в названии инструмента брокера (например, EURUSDecn)

terminal_path:\\Program Files\\PrimeXM FX Bridge - необходим, чтобы EverestFX TErminal API настраивал торговый терминал в автоматическом режиме:

а) положения таблиц для оптимального распознавания текстовой информации;

б) положения меню установки ордеров;

в) другое.

Указывать путь к папке с установленным торговым терминалом.

Рис. 1. Таблица должна быть требуемой высоты

Рис. 2. Положение таблицы управления ордерами

Рис. 3. EverestFX Terminal API

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


EverestFX Delta Core

Navigation: »No topics above this level«

EverestFX Delta Core

 Return to chapter overview

EverestFX Delta Core является основой системы. Производит анализ рыночной ситуации, отправляет сигналы управления системе EverestFx Terminal API.


Валютные пары

Navigation: EverestFX Delta Core >

Валютные пары

 Return to chapter overview

В меню навигации "Symbols" отображаются доступные инструменты для проведения арбитражных операций.

Возможны следующие состояния инструмента:

а) мигание зеленым - нормальное функционирование алгоритмов. Система готова к торговле по инструменту;

б) мигание красным - несовпадение времени между терминалами;

в) серый цвет - инструмент по каким-либо причинам не будет использоваться в работе. К возможным причинам можно отнести следующие: система не смогла найти условия, подходящие для совершения прибыльных арбитражных операций.

В фигурных скобках указывается текущее расхождение по инструменту.

Рис. 1. Список валютных пар

Рис. 2. Список валютных пар

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


Информация о текущем состоянии инструмента

Navigation: EverestFX Delta Core > Валютные пары >

Информация о текущем состоянии инструмента

 Return to chapter overview

Рис. 1. Информация о текущем состоянии инструмента


Система поиска оптимальных арбитражных точек входа

Navigation: EverestFX Delta Core > Валютные пары >

Система поиска оптимальных арбитражных точек входа

Return to chapter overview

Основными условиями арбитражной торговли являются пороги открытия и закрытия (в пунктах цены расхождения брокеров).

К таким условиям относится такая комбинация уровней открытия и закрытия, при которой прибыль будет наибольшей (Рис.1).

Рис. 1. График ценовых расхождений двух брокеров

Для поиска оптимальных уровней в ПО EverestFx Delta Core присутствует встроенный алгоритм, принцип действия которого заключается в следующем:

1) Определяется статистическое распределение разниц курсов двух брокеров (см. Статистический анализ);

2) Генетический алгоритм определяет оптимальные уровни открытия и закрытия, используя при этом исторические данные;

Рис. 2. Лучшая хромосома генетического алгоритма

На рис. 2 показана лучшая хромосома генетического алгоритма ( цена открытия 4 пункта, закрытия - 0 пунктов ). При использовании этих параметров потенциальная прибыль с учетом спрэдов брокеров составляет 71.5 пунктов.

Расчет оптимальной стратегии производится при каждом запуске EverestFX Delta Core.

В алгоритме поиска оптимальных арбитражных точек входа имеется дополнительная возможность выставления уровней открытия / закрытия вручную.

Рис. 3.Настройка уровней открытия/закрытия вручную

После настройки уровней открытия/закрытия необходимо их сохранить (кнопка "save thresholds") для дальнейшего использования.


Состояние систем анализа инструмента

Navigation: EverestFX Delta Core > Валютные пары >

Состояние систем анализа инструмента

 Return to chapter overview

Рис. 1. Состояние систем анализа инструмента

Для каждого инструмента постоянно отслеживаются следующие состояния:

1) Открыто N работ {Opened N jobs}

Позиции не открываются, если по текущему инструменту уже открыто N арбитражных позиций;

2) Разница > M пунктов{∆>m pips}

Достигнут уровень открытия;

3) Синхронное время на терминалах{Syncronous quotes time}

Время на терминалах совпадает;

4) Контроль тиков{Ticks Control}

Котировки с первого и второго терминалов приходят синхронно за отведенный интервал времени;

5) Подтверждение от системы технического анализа{Confirmation from Technical Analysis}

6) Подтверждение от системы нейросетевого анализа{Confirmation from Neural Networks}

Примечание: мигание красным означает запрет со стороны выбранного алгоритма, зеленым - разрешение.

Для открытия важно соблюдение следующих условий инструмента: 1,2,3,4,5,6

Для закрытия важно соблюдение следующих условий инструмента: 3,4,5,6


Статистический анализ по инструменту

Navigation: EverestFX Delta Core > Валютные пары >

Статистический анализ по инструменту

 Return to chapter overview

Модуль статистического анализа выполняет следующие функции:

1) Определяет ценовое расхождение у брокеров по инструментам;

Рис. 1. Ценовое расхождение у брокеров по текущему инструменту во времени

2) Определяет распределение ценовых расхождений брокеров;

Рис. 2. Распределение ценовых расхождений брокеров

На основании результатов, показанных на рис.2, можно сделать вывод, что расхождние в 5 пунктов встречается 98 раз.


Технический анализ по инструменту

Navigation: EverestFX Delta Core > Валютные пары >

Технический анализ по инструменту

 Return to chapter overview

Важным элементом принятия торговых решений является подтверждающий сигнал от алгоритма технического анализа, суть которого в поиске рыночного состояния, при котором курсы брокеров по текущему инструменту меняются несущественно. Это делается для того, чтобы проскальзывания цены при открытии позиций были минимальны.

Рис. 1. Технический анализ по инструменту


Нейросетевой анализ по инструменту

Navigation: EverestFX Delta Core > Валютные пары >

Нейросетевой анализ по инструменту

 Return to chapter overview

Использование нейронных сетей в рамках этого проекта обусловлено следующей причиной:

Функция ценовой разницы во времени по инструменту у брокеров меняется скачкообразно, что является проблемой при принятии торговых решений;

Таким образом, нейронные сети в проекте EverestFx Delta Core занимаются предсказанием такого состояния, при котором последующие значения ценовой разницы лежат в некотором небольшом доверительном интервале значений.


Настройки программы

Navigation: EverestFX Delta Core >

Настройки программы

 Return to chapter overview

Файл настроек EverestFX Delta settings.txt ПО EverestFx Delta Core расположен в папке программы.

1) Список сетевых соединений ( не dial-up ). Используется название адаптера

//internet connections Lan (network_name1;network_name2;network_name3)

lan_connection_name:Realtek PCIe FE Family Controller;

2) Имя сервера, на котором установлены виртуальные машины

//EverestSecurity host

security_host:host_name

3) Список dial-up соединений

//dial-up internet connection (network_name1|username,password;network_name2|username,password;network_name3|username,password;)

//3G|mobile,internet

dial_up:;

4) название БД

//data base name (needs for multi-testing)

db_name:delta

5) торговые инструменты, по которым будет проводиться анализ

//trading instruments SYMBOL_NAME|Open_pips;Close_pips;Lot_Ke;Lot_Pe

system_symbols:EURUSD|3.33;2.6;140;0.85,GBPUSD|4.0;2.0;130;0.85,USDJPY|4.0;2.0;100;0.85,EURGBP|4.0;2.0;70;0.85,USDCAD|4.0;2.0;140;0.85

6) максимальное количество работ по инструменту

//maximum jobs for the instrument

jobs_maximum:1

7) сохранять в автоматическом режиме параметры лучшей комбинации открытия/закрытия позиций.

Выполняется алгоримом "система поиска оптимальных арбитражных точек входа / выхода"

//use best strategy result

use_best_result:no

8) включить алгоритм "система поиска оптимальных арбитражных точек входа / выхода"

//enabling auto-searching algorithm for opening and closing deals

find_optimal_distribution_for_instruments:yes

//send a message to controlling manager

send_SMS_to_manager:yes

//send a massages to

SMS_numbers:79999999999,79999999999

//send a message to super-manager

send_SMS_to_supermanager:no

9) Параметры электронной почты, с которой будут отправляться торговые отчеты

//send e_mails from

email_everest_smtp:smtp.live.com,25

email_login:everest_fx_report@hotmail.com

email_password:dsS3hNfjr3dHzLs92AxA

10) Куда отправлять торговые отчеты

//daily trading report on e-mails

email_report:everest_fx_report@hotmail.com,

11) Разрешить торговлю по инструментам

//allow trade

trading_enabled:yes

12) Спрашивать подтверждение всех торговых операций

//permit trading operations

open_deal_confirmation:no

13) Алгоритмы подтверждения

//trading conditions

tick_control_enabled:yes

neural_net_enabled:yes

strategy1_enabled:yes

strategy2_enabled:yes

strategy3_enabled:yes

14) Отключение выбранных инструментов по отдельности

//permission to trade separately on the instrument

EURUSD_permission:yes

GBPUSD_permission:yes

USDJPY_permission:yes

USDCHF_permission:yes

EURGBP_permission:yes

USDCAD_permission:yes

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


Инструмент Jobs

Navigation: EverestFX Delta Core >

Инструмент Jobs

 Return to chapter overview

Для удобства работы по арбитражному принципу сделки брокеров объединяются в отдельный класс Jobs и контролируются совместно.


Система анализа пригодности пар брокеров

Navigation: EverestFX Delta Core >

Система анализа пригодности пар брокеров

 Return to chapter overview

Для существенной экономии времени ( при поиске подходящих для арбитражной торговли брокеров ) реализована "Система анализа пригодности пар брокеров". Результатом работы этой системы является отчет в формате MS Office Word.

Система формирует отчет при каждом запуске системы на основании котировок в базе данных, загруженных индикатором MQL EverestDelta3_0.mq4.

Рис. 1. Отчет по паре брокеров

Примечание: Отчет сохраняется в папку EverestFX Delta Core Folder\Reporting\


Система формирования торгового отчета

Navigation: EverestFX Delta Core >

Система формирования торгового отчета

 Return to chapter overview

Для удобства слежения за ходом торгов каждые 6 часов отправляется отчет о совершенных торговых операциях на электронную почту.

Рис. 1. Торговый отчет

Рис. 2. Торговый отчет

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


EverestFX Services Control

Navigation: »No topics above this level«

EverestFX Services Control

 Return to chapter overview

EverestFX Services Control является дополнительным ПО, обслуживающим работу EverestFX Delta

EverestFX Services Control выполняет следующие задачи:

1) добавление/удаление пользователей EverestFX Delta;

2) администрирование серверов, на которых установлено ПО EverestFX Delta;

3) запрет исполнения ПО EverestFX Delta;

4) удаленное управление ( remote desktop connection ) с использованием EverestFX Remote Desktop;

5) контроль и управление всеми доступными интернет - соединениями.

Рис. 1. EverestFX Delta

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


Пользователи системы

Navigation: EverestFX Services Control >

Пользователи системы

 Return to chapter overview

Для работы в системе EverestFX Services Control необходимо иметь учетную запись пользователя.

Рис. 1. Запрос аутентификации

В системе EverestFX Services Control имеется два типа учетных записей: Owner и RDP_User.

Пользователь Owner имеет следующий набор прав:

а) Разрешение/запрет работы сервера с текущим уникальным идентификатором (unique_ID);

б) Просмотр списка неавторизованных серверов с подробной информацией о них;

в) Добавление сервера в список авторизованных;

г) Добавление/удаление пользователя ПО EverestFX Services Control с возможностью присвоения ему прав "Owner";

д) Администрировать систему управления доступными интернет-соединениями;

е) Remote desktop connection со всеми серверами, где установлено ПО EverestFX.

Пользователь User имеет следующий набор прав:

а) Администрировать систему управления доступными интернет-соединениями;

б) Remote desktop connection с доверенными пользователю серверами, где установлено ПО EverestFX.


Администрирование

Navigation: EverestFX Services Control >

Администрирование

 Return to chapter overview

Рис. 1. Добавление/удаление пользователей EverestFX Services Control

Рис. 2. Операции с серверами EverestFX Delta


Управление интернет-соединениями

Navigation: EverestFX Services Control >

Управление интернет-соединениями

 Return to chapter overview

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.